septembre 2016 (2)

Dell XPS (2015), carte Intel i915 et kernel >= 4.6

Depuis le passage de Fedora au kernel 4.6, mon portable (Dell XPS 13 édition 2015) freeze au lancement de Gnome... Je n'avais pas pris le temps de corriger ça et je me disais que le 4.7 le corrigerait bien... Malheureusement ce ne fût pas le cas à là sortie du kernel 4.7. En faisant un peu de recherche il semblerait que les drivers i915 soient daubés depuis la 4.6 et ceci entraine toutes sortes de bugs divers. Du coup je me suis lancé dans la recherche de paramètres à passer au kernel pour arriver enfin à faire tourner mon XPS avec un kernel 4.7. Et les bons paramètres semblent être les suivants :
 

 

Lire la suite

Certificat Let's Encrypt configuré au top

Dernièrement j'ai dû, pour le compte d'un client, faire une étude pour rendre un site compatible ATS au niveau de la sécurité. Il en est ressorti plusieurs problèmes :

  • La CVE-2016-2107 pour cause de lib-openssl pas à jour.
  • Des Ciphers et des protocoles pas top...
  • Pas de  PFS.

Le bilan : une note de "F".

Du coup, j'ai regardé un de mes domaines SSL et je me suis rendu compte que moi aussi je n'étais pas au top... Du coup une petite correction s'imposée.

Lire la suite

Attribution - Partage dans les Mêmes Conditions 4.0 International