eZ Publish 4, php 5.2, CentOS 5, Remi et la spb-box

Que du beau monde dans un seul billet...

A la lecture du très instructif commentaire de Paul Borgermans laissé à la suite de mon billet sur la première alpha d'eZ Publish 4.0; et l'annonce qu'eZ 4.0 ainsi qu'eZ Components iraient plus vers un compatibilité php 5.2 que 5.1 : j'ai décidé de mettre à jour la version de php de la spb-box.

Pour cela, j'ai fait confiance à l'ami Remi (Attention prononcer Remi et surtout pas Rémi) et à son dépôt. Pour ceux qui ne connaisse pas Remi, surnommé dans le milieu "Serial Builder", il propose les dernières versions php/MySQL pour Fedora mais aussi pour les RHEL 4 & 5.

Une petite ligne de commande :

[bash]
root@spb-box ~> wget http://remi.collet.free.fr/rpms/el5.i386/remi-release-5-2.el5.remi.noarch.rpm \
rpm -Uvh remi-release-5*.rpm \
yum --enablerepo=remi update php

Et me voila en php 5.

[bash]
root@spb-box ~> rpm -qa php
php-5.2.4-1.el5.remi

Tenant à activer le dépôt de Remi par défaut (il est très réactif au niveau des mises à jour) mais ne tenant pas à mettre à jour mon serveur MySQL, j'ai configuré le dépôt de la sorte.

[bash]
[remi]
name=Les RPM de remi pour Enterprise Linux 5 - $basearch
baseurl=http://remi.collet.free.fr/rpms/el5.$basearch/
    http://iut-info.univ-reims.fr/remirpms/el5.$basearch/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
exclude=mysql mysql-server mysql-libs

A force de mettre des clauses exclude dans mes fichiers repo, j'en fini par croire qu'il faudrait inventer un clause include...

Attribution - Partage dans les Mêmes Conditions 4.0 International