ATI Mobility X700 sous Fedora Core 5

Après l’installation aisée de mon ATI Mobility X700 sous Fedora Core 4 (Stenz), je me suis lancé dans une nouvelle installation de Fedora Core 5 (Bordeaux) sous mon portable.
Malheureusement, les problèmes ont eu lieu dès l’installation mais ils ne sont nullement insurmontables.

L’installation de Fedora Core 5 (Bordeaux) :

L’installation se passe sans problème jusqu’au lancement de l’interface graphique de l’installateur Anaconda. Le problème est que la carte graphique est bien reconnue, les drivers bien utilisés, mais le moniteur du portable mal configuré.
Il existe 3 solutions :

  • Installer en mode texte.
  • Brancher un moniteur externe.
  • La meilleure solution et d’utiliser temporairement les drivers « vesa » et de taper « linux vesa » avant de commencer l’installation.

Installation des drivers Open Source :

Ce sont ces même drivers qui ont posés le problème d’écran noir lors de l’installation de Bordeaux. Nous allons donc bien configurer notre serveur X pour ne plus rencontrer ce problème.
Pour cela en root, éditez le fichier « /etc/X11/xorg.conf :

Section "Device"
      Identifier     "Videocard0"
      Driver     "radeon"
      VendorName     "Videocard vendor"
      BoardName     "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
      Option     "MonitorLayout" "LVDS, NONE"
 EndSection

Installation des drivers Closed Source officiels de chez ATI en provenance de Livna :

Ce sont les drivers officiels d’ATI mais repackagés parfaitement pour Fedora Core 5 par Livna.
Pour rappel, l’installation des drivers téléchargés en direct du site d’ATI ne vous posera que des problèmes : écrasement de librairies d’X, etc… Vous êtes donc invités à utiliser le dépôt Livna et à configurer convenablement votre gestionnaire de paquet Yum.

L’installation est très rapide puisqu’il suffit de taper :

yum install kmod-fglrx

Attention, SELinux à un comportement extrémiste et bloque chez moi l’utilisation des drivers ATI. La solution est alors de désactiver SELinux qui pose bien des problèmes (sujet d’un prochain billet).

/usr/sbin/setenforce 0

Remarque :

  • Le kernel originel sortie avec Fedora Core 5 (2.6.15-1.2054_FC5) ne permet pas l’installation de kernel-module (kmod à présent) Closed Source. Il vous faudra donc mettre à jours votre kernel vers la version 2.6.16-1.2080_FC5 ou l’une des suivantes.
  • Sous Fedora Core 5, les kernel-modules deviennent des kmods et se mettent à jour en meme temps que le kernel.

Commentaires

cLint

De cLint le 1 avril 2006

Nickel ....
Ca fait un moment que je luttais avec ce probleme et voila que je tombe sur ce petit ticket fait bien comme il faut.
Merci ;)

Tinyturtle

De Tinyturtle le 1 avril 2006

Es tu sûr que les pilotes soient vraiment pris en charge après ton redémarrage ?
Car il semble que malgré cela (j'avais fait la même chose que toi à l'époque où j'ai voulu faire marcher cette carte (version Mobility pour ma mienne en PCIE, tu ne précises pas la tienne) et bien que le chargement semble s'effectuer, l'affichage correct avec un Xorg dont la valeur du driver est bien fglrx, et le module bien chargé, lsmod en attestant. Un petit fglrxinfo et test avec la version custom de glxgears dénotent un fonctionnenement incorrect (cf. le message d'erreur suspect sur le DRI, la présence de MESA, et le score minable de glxgears). Je précise que j'ai testé avec ou sans les commentaires concernant le module DRI.

Voilà, à toi de me répondre un petit mail à anthony dot herbe at free dot fr me ferait bien plaisir, si tu as la solution... J'ai beau essayé la version de Livna, il semble que l'incompatibilité entre Xorg version 7 et les pilotes propriétaires d'ATI soient la source majeure de nos soucis.

P.S.: Je profite de ce message pour te remercier concernant ton billet sur l'ATI REMOTE WONDER II, car il m'a bien aidé. J'ai lutter pendant dès mois à la faire marcher et il me manquait tout comme toi, les modules de ATRPMS comme tu l'as signalé. Au passage, ces modules semblent disponibles d'origine ou compilés directement dans les noyaux de la FC5.

Un petit billet sur la télécommande et la configuration de soft comme un lecteur PDF ou un lecteur de présentations seraient intéressant pour des démos avec vidéos projecteurs. ;-)

Bonne lecture... :D

LLaumgui

De LLaumgui le 1 avril 2006

Chez moi mes scores a glxgear sont tout à fait honorable.
Tout marche nickel sauf les jeux pour le moment mais je pense que ça vient des librairies qui me manque (SDL et autre)

Les drivers ATI sont incompatibles avec Xorg 7, c'est pour ça qu'il faut prendre la version livna.

StarstzaR

De StarstzaR le 1 avril 2006

chez moi ça ne marche pas :(

J'ai fais ce qui est dit (d'ailleur j'ai du rééditer le xorg.conf car après l'install de kmod-fglrx il avait changé) et j'obtient un affichage completement instable (genre canal+ en crypté)! c'est à peine lisible! :(

Une idée?

PS: j'ai FC5 noyau 2.16; un écran LCD 1920x1200; j'ai essayer le #load "dri" ça change rien; j'obtient 814 fps avec glxgears

LLaumgui

De LLaumgui le 1 avril 2006

Ca ne sert a rien de modifier ton xorg.conf avant d'instaler les drivers car ces derniers modifient ton xorg pour le reconfigurer de mannière convenable.
Sinon, ta résolution me semble un peut grosse pour l'écran... Essais de la monter progressivement en commancant pas 1280x800 qui est la configuration normale pour un portable.

bochecha

De bochecha le 1 avril 2006

Bonjour

Je viens de suivre la procedure pour installer les drivers ATI (ceux de livna).

J'ai reboote, et je vois pas vraiment de difference...

Comment je sais si ca marche bien ?

LLaumgui

De LLaumgui le 1 avril 2006

glxgear pour voir les fps... Sans accélération 3D ca plante d'entré normallement.

bochecha

De bochecha le 1 avril 2006

4290 FPS c'est bien ?

LLaumgui

De LLaumgui le 1 avril 2006

Ca dépend de ta carte ;-) (ma 6600GT tape à plus de 9.000).
Mais le score à glxgear prouve que l'accélération 3D est bien en fonction....

Test des jeux comme Tremulous (Besoin des libs SDL) ou Nexuiz, dispo sur extra.

bochecha

De bochecha le 1 avril 2006

ATI Radeon Mobility X700...

Et donc je tourne dans les 4300 FPS...

Sinon dans Bureau->Administration, y a un nouveau truc qui est apparu avec l'installation des drivers, j'avais pas vu avant :
ATI-fglrx parametres d'affichage
Et dedans, je peux configurer des trucs pour ma carte video...

Par contre, a "card name" il me met "unknown", c'est normal ? comment je peux changer ?

En tout cas merci beaucoup pour le tuto :D

LLaumgui

De LLaumgui le 1 avril 2006

Dans xorg.conf ?

linux

De linux le 1 avril 2006

le site http;//rpm.livna.org ne répond pas.
mauvaise manoeuvre de ma part?
J'essaie d'installer Fedora Core 5 sur mon portable Toshiba Satellite M-60-189.
Est ce possible? et si je n'abuse pas quelques conseils seraient utiles.
Votre blog pourra m'aider. Merci.

linux

De linux le 1 avril 2006

je précise que ce portable a pour carte graphique ATI Mobility X700 et google m'a conduit ainsi sur votre blog.

LLaumgui

De LLaumgui le 1 avril 2006

http://rpm.livna.org/. Ca marche parfaitement.

linux

De linux le 1 avril 2006

a 21h18 cela fonctionne ! merci.

Burn

De Burn le 1 avril 2006

Salut
merci pour le plan mais chez moi ça ne fonctionne pas !
apres l install et la modif de xorg.conf fedora boot en mode console plus aucun graphique et x plante !!!

heu . ? une idée ???

merci

Burn

De Burn le 1 avril 2006

erf .. j ai trouver .. SELinux evidement ..
ne riez pas !
;-)

Zigi

De Zigi le 1 avril 2006

L'installation du driver ATI de Livna a enlevé la commande de démarrage de Metacity (gestionnaire de fenêtres Gnome) lors de la connexion à une session. Il faut donc aller remettre la commande dans:

Session --> Programmes au démarrage --> ajouter --> /usr/bin/metacity

LLaumgui

De LLaumgui le 1 avril 2006

C'est les symptomes d'un problème de SELinux... Les drivers Livna n'y sont pour rien.

Tempus

De Tempus le 1 avril 2006

Salut,
j'ai essayer egalement d'installer la Fedora Core 5, avec une ati X850 XT, mais comme il est écris, il y a un écran noir lorsque l'interface graphique de l'installateur se lance.
Je suis tomber sur ce blog pensant avoir trouver la solution, (malgrès que ce soit une PC de bureau, avec écran CRT), mais lorsque qu'au boot de demarrage je tappe : linux vesa.
Là sa continue et au moment ou l'interface graphique se lance mon écran s'éteint... Je ne comprend pas pourquoi et je ne vois pas quoi faire à part l'installer en mode texte (et là je suis pas très chaud....)

Si quelqu'un peut m'apporter de l'aide...

darkness45

De darkness45 le 1 avril 2006

voila j'ai le même problème avec ma X-700, je voudrais savoir avant de me lancé dans le mode non-graphique, si le problème d'affichage se refera avec l'interface graphique de fedora,
si quelqu'un pourrais m'aidée ou même une entraide avec des personne qui on le même problème (pour trouver la solution ensemble) ça serai super cool
ps: mon adresse msn: dodo_of_darkness@hotmail.fr

LLaumgui

De LLaumgui le 1 avril 2006

linux vesa et ça marche ;-). Ubuntu 6.06 aura le même problème apparmeent.

darkness45

De darkness45 le 1 avril 2006

ok merci 'jai pu installer linux maintenant il y a un probleme avec UDEV (ca serai un probleme venant du PCMCIA) ...?? aurai tu quelque conseil bien expliqué, car dans les forums je comprend pas toujours

mxlaser

De mxlaser le 1 avril 2006

Bizarre apres avoir installer le pilore ati reconditionner il n'apparait toujours pas sous flgrxinfo (ca ecrit mesa gl etc) et le test glxgears donne un score minable qui confirme que le pilote a ete installer mais apparament pas activer.

La commande ati-fglrx-config-display enable retourne ceci :

Traceback (most recent call last):

 File "/usr/sbin/ati-fglrx-config-display", line 184, in ?    if os.access(output_file, os.F_OK):

TypeError: coercing to Unicode: need string or buffer, NoneType found

mxlaser

De mxlaser le 1 avril 2006

Ca y est j ai reussit Bizarrement apres un yum update et re xconf ca a prit le drivers ati.

deuxrois

De deuxrois le 1 avril 2006

Hello
je viens de tomber sur ce tuto pas mal présenté. Je suis entrain de reprendre espoir avec. Au passage: J'ai un toshiba M70-207 avec une carte ATI Mobility Radeon X6000 SE

Nul!

De Nul! le 1 avril 2006

bjr à tous, SVP aidez moi je suis trop nul pour comprendre mon problème: Voilà, on m'a installé fedora core 5 et je n'arrivai pas à acceder au bureau car il y a incompatibilité avec ma carte graphique en bref je ne sais pas trop vous expliquez...voilà ce qui s'affiche quand je tape "startx":
Failed to load/usr/lib/xorg/modules/drivers/fglrx_drv.so
failed to load module "fglrx" (loader failed,7)
No drivers avaible
fatal server error
no screens found
XIO: fatal IO error 104 (connection reset by peer) on X server: "0.0"
Voilà un peu je trouve comme qui fait ca ne marche: Please aidez moi. je ne connais rien en ses choses là.

Malek

De Malek le 1 avril 2006

Salut, j'ai un portable Acer 4101, le problème de la carte graphique ATI Radeon X700 est résolu mais lorsque l'ordinateur est en mode graphique (gnome par exemple), parfois l'ordinateur se plante et je ne sais pas qu'est ce que je peut faire, svp aidez moi

Les commentaires pour ce poste sont fermés.