Glest sous Fedora Core 4 (x86)

Guillaume Kulakowski par Guillaume Kulakowski dans Fedora 5 octobre 2005 5
Fedora

Glest est un jeu de stratégie en temps réèl et en 3D. C’est un clone de WarCraft mais en version GNU/GPL. Ce qui ne gâche rien, Glest est multi-plateforme, et je m’intéresserais ici à l’installation de sa version Linux.

Glest is a project for making a free 3d real-time customizable strategy game.

Current version is fully playable, includes single player game against CPU controlled players, two factions with their corresponding tech trees, units, buildings and some maps.

Glest en action

Installer les drivers de votre carte graphique :

Pour ça je vous conseil ce billet issu du blog de l’ami Titax.

Les dépendances :

Si vous avez suivie ce tutoriel, votre yum est parfaitement configuré. Ne vous reste plus qu’à taper :

yum install openal xerces-c

Téléchargement et installation :

Le problème des dépendances étant résolu, vous pouvez télécharger et installer le jeux (version Loki Installer).

Ca marche pas !

Une fois le jeux installé et la commande ./glest lancée, vous vous trouvez confronté à ce message :

./glest: line 63: 5967 Segmentation fault ./$GAME_BINARY "$CMD_ARGS" "$@"

Pas de panique, il vous suffit de lancer le jeux comme cela :

SDL_AUDIODRIVER=dsp ./glest

Là, nouveau message d’erreur :

Exception: Your system doesn't support OpenGL version 1.3
 You may solve this problem by installing your latest video card drivers

Or, si vous avez suivie la première étape et mis vos drivers à jour, vous devez supporter la version 1.3. Il vous suffit de désactiver la vérification de l’OpenGL en éditant le fichier glest.ini>et en passant la valeur CheckGlCaps à 0.

Bon jeu !

Commentaires

TitaX

De TitaX le 5 octobre 2005

C'est très bien, il y a de plus en plus de jeux qui fonctionne sous linux !!
www.wesnoth.org/start/1.0...

bochecha

De bochecha le 5 octobre 2005

Sympa le tuto...

Par contre, j'essaie de l'installer sur Fedora 5, et l'install des dependances par yum me renvoit :
Parsing package install arguments
No Match for argument: xerces-c
Nothing to do

Les noms des dependances ont changes pour fedora 5 ? Ou peut etre il n'y en a plus besoin...

Du coup,comment installer dur FC5 ?

Merci

LLaumgui

De LLaumgui le 5 octobre 2005

Je viens de voir qu'effectivement elles ne sont pas dans yum... Faut tester sans, mais à mon avis ça ne marchera pas.

bochecha

De bochecha le 5 octobre 2005

En fait openal est deja installe sur mon systeme...

Reste donc a trouver xerces... :-(

Jakatak

De Jakatak le 5 octobre 2005

Pour info il existe une version bêta reseau de glest ...

Les commentaires pour ce poste sont fermés.